Cat S60 Forum

General CAT S60: some slow apps

I have noticed that there are a few apps that are just unusable on the CAT S60.
  • the Facebook app - though I could not get it to function correctly on the much more powerful Sony Z5 either, where it would just never update the wall. On the S60 though the app just does not work. Facebook works very well in the Android Chrome browser though.
  • Deezer app: here it works very reluctantly, making it very close to unusable too. I am close to uninstalling it. Actually, it did not seem to work on the Sony Z5 either, which is why I cancelled my subscription to that service. On the laptop, Deezer works very well. Sadly they don't allow one to use the browser version in the phone, as Facebook does.
  • Soundcloud: I also uninstalled that app as it was too slow.
But many other apps work fine: I have no trouble with the YouTube app, WhatsApp works great, Facebook works fine inside of Chrome, I have listened to french radio stations without any trouble, Google Maps works very well, ...

Are these apps just badly written? Is the CAT S60 processor, that is a middle range processor too slow? Will perhaps the next version of Android Nougat help?


#1 bblfish, Sep 26, 2016 Last edited: Sep 28, 2016
I tried Deezer and soundcloud for a day yesterday on and off and had no issues. I don't use facebook so I can't check that one.

Maybe try wiping the data for each one and restart?
#2 cavell219, Sep 30, 2016
It looks like you are right. After re-installing and deleting the storage (I had assumed deleting the app deleted the storage too), as well as giving all the requested rights to Facebook and Deezer seems to give much better results.... It's working as expected now...

I am wondering if these apps are not written for the previous version of Android Lolipop and earlier that required the user to accept all permissions requested by an app in one click. It could be that selective and security conscious user selection of permissions allowed by Marshmallow breaks those apps, which then perhaps go into infinite loops trying to e.g. get user pictures from the address book, and on failure throw exceptions.... That would explain the difference in behavior.
#3 bblfish, Sep 30, 2016
No, the answer was simply to do a factory reset of the phone. The CAT S60 started working perfectly well after that.
It is very likely that I just put some important libraries on energy saving mode by mistake.
#4 bblfish, Dec 7, 2017
Maybe cleaning the app cache might save you some grief and time @bblfish. Try File Go from Goggle to do that. Reinstalling apps is way to time consuming.
#5 dontpanicbobby, Dec 7, 2017
Too late, I did a factory reset a while ago and everything worked beautifully from then on.
Perhaps if someone else comes across this post with the same problem, they could try File Go.
In my case I am pretty sure it was me having set the energy saving mode on system libraries or something like that. Even new users had the same problem, and even with apps that I had never installed...
#6 bblfish, Dec 7, 2017
Cool. Try that next time things slow down.
#7 dontpanicbobby, Dec 7, 2017